Hlavní navigace

Ve Firefoxu přes víkend nefungovala žádná rozšíření, mohl za to expirovaný certifikát

Sdílet

Karel Wolf 6. 5. 2019

Ve Firefoxu od soboty do neděle přestala fungovat prakticky veškerá nainstalovaná rozšíření, dokonce ani jazykové balíčky, opravená verze vyšla až v noci z neděle na dnešek.

Příčinou problému byl expirovaný certifikát, který společnost používá při podepisování extenzí prohlížeče. Firefox totiž od určité doby vyžaduje, aby byla z bezpečnostních důvodů rozšíření v běžných verzích prohlížeče nejprve podepsané Mozillou. 

Mozilla vydala aktualizované verze prohlížeče, které problém provizorně řeší, jedná se o verzi 66.0.4 v případě standardní desktopové edice a Android edice a 60.6.2. v případě ESR edice. Společnost ale přesto upozorňuje, že nejde o kompletní řešení a řada rozšíření stále nemusí ani poté správně fungovat. Řešením by v takovém případě měla být kompletní reinstalace a reaktivování doplňků. 

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 7. 5. 2019 7:48

    eking

    Nu což, podle přísloví, "I mistr tesař se někdy utne." Každopádně pochvala za dobrou komunikaci této události a za snahu pomoci na stránkách české Mozilly. https://www.mozilla.cz/

  • 7. 5. 2019 9:37

    bez přezdívky

    Mohl by to být i nástroj na to, jak donutit uživatele používající staré verze FF jejich k opuštění.
    Používám FF 56 kvůli doplňku Tab Mix Plus, který není kompletně předělaný na nový systém doplňků používaných od verze 57.
    Teď mi doplněk nefunguje, protože i FF 56 mi hlásí, že doplňky "nemohly být ověřeny".
    Jenže Mozzilla neodstranila chybu přímo, ale jen vydáním nové verze FF 66 (plusminus).
    Zkusil jsem doporučení v článku odinstalovat a nainstalovat doplňky znovu, ale přesto, že mám FF 56, ve vyhledávání doplňků není starý Tab Mix Plus k nazelení (ač dosud mnou každodenně používaný).
    Takže teď nemohu používat FF 56 se starými doplňky a musím jedině přejít na aktuální verzi.
    Nějak si s tím poradím, ale většina běžných uživatelů může jen rezignovat a přejít na novější verzi.
    Pokud existuje nějaká statistika používání FF podle verzí, bylo by zajímavé ji nyní sledovat, jak se změní.

  • 7. 5. 2019 14:09

    8AN

    Mě ve Firefoxu 66 stačilo v about:config vypnout xpinstall.sig­natures.requi­red a po chvíli rozšíření zase začaly fungovat i bez restartu prohlížeče. Nevím, jestli je tenhle přepínač dostupný i ve verzi 56, ale třeba to pomůže.

  • 7. 5. 2019 13:15

    bubla

    Ale odejít kam? Chrome? Tam jsem nenašel náhradu pro všechny pluginy, které používám :-( Opera? Edge? Tam to bude s výběrem pluginů ještě horší...