Hlavní navigace

Google Chrome čeká omezení podpory plug-inů, které přesto budou fungovat?

Jiří Macich ml.

Chystaný Google Chrome 33 omezí podporu plug-inů využívajících API ještě z dob prohlížeče Netscape Navigator. Do konce roku chce Google podporu těchto plug-inů zrušit úplně.

Google stále trvá na tom, že ve svém webovém prohlížeči časem přestane zcela podporovat Netscape Plug-in API (NPAPI), což je historicky první standard pro uživatelské doplnění nových funkcí do webového prohlížeče. Podle oznámení z loňského podzimu již od začátku letošního roku měl Google Chrome podporovat jen šest nejpoužívanějších plug-inů využívajících NPAPI.

V lednu vydaný Google Chrome 32 omezení podpory plug-inů nepřinesl, ovšem betatestovaný Google Chrome 33 z plug-inů využívajících NPAPI hodlá podporovat jen půl tuctu těch nejčastěji používaných. Je mezi nimi v tomto pořadí Silverlight, Unity, Google Earth, Java, Google Talk (Hangouts) a Facebook Chat (Skype).

Flash Player, který je již součástí instalace prohlížeče Google Chrome, cca dvě desetiletí staré Netscape Plug-in API již nepoužívá. Stejně tak plug-in pro zobrazení PDF dokumentů v okně prohlížeče založený na technologii společnosti Foxit Software.

EBF17 tip Braverman 2

Kompletní zrušení podpory NPAPI si Google na majoritních platformách Windows a OS X naplánoval na konec letošního roku. Nicméně Google Chrome pro Linux a Chrome OS se ukončení podpory veškerých plug-inů využívajících NPAPI mají dočkat již letos v dubnu.

Google místo plug-inů propaguje nejen webové technologie v čele s HTML 5, ale i vlastní technologii Portable Native Client, která umožňuje pro účely webových aplikací používat nativní kód v jazyce C/C++ napříč prohlížeči. Původní Native Client vyžadoval plug-in v prohlížeči (je součástí Google Chrome), ale Portable Native Client již nikoliv.  

Našli jste v článku chybu?